New App API Level 31 In Console

For New Apps

1 Like


Not yet

1 Like

I tried to build a simple test app (APK) on the test server (targetSdkVersion=31) and checked the Manifest. Missing there
in every <activity ...>

Therefore, the APK cannot be installed on Android 12+ devices.


@Souvik @abhijith

1 Like

I’m looking into it


Yes, @Anke is right. I created a simple app on the with just a text box and a button. When I tried to install the app on my phone then it showed the error “There was a problem parsing the package.” So, i decompiled that same apk using Apk Editor Studio and checked the Manifest.xml file and saw that android:exported=“true” was missing from the activity. I added that and then recompiled the apk. After that the apk was successfully installed and run on my phone. I’m attaching the apk file before i edited the Manifest and the apk after I edited the Manifest file for reference. I’m also attaching both the Manifest files.

App without editing manifest.apk (4.7 MB)

App after editing manifest.apk (4.7 MB)

Manifest after editing.xml (1.7 KB)

Manifest without editing.xml (1.7 KB)

1 Like

Only You Can Do This. I have try many time but error not gone.

I am trying many time i am chang successful but problem not solve :pensive:.

problem in beta server a12 api 31

@Anke there were some issues in the buildserver. It should be working now,



But my simple test app does not work on Android 11+ (of course this issue is NOT related to targetSdk 31):

because WRITE permission must (incorrectly) be declared in the Manifest also on Android 11+
(and this is not the case if I set DefaultFileScope = Legacy, as with AI2).

FileScope_Android11plus.aia (2.2 KB)

I pointed out this bug countless times in the AI2 forum!


We were actually focusing on updating the Target SDK as the deadline is here, but now we will give priority to the bugs.

Should be fixed in next patch.

1 Like

And you already have fewer bugs than AI2 (at least with the File component). :+1:

(I don’t even want to talk about Kodular. The bugs there are no longer enumerable!)

1 Like

As far as i understand. The Write Permission is not required for Android 11 and above:

From the Google Documentation:

if your app targets Android 11 (API level 30) or higher, the WRITE_EXTERNAL_STORAGE permission doesn’t have any effect on your app’s access to storage.

Just one example:
The File.ListDirectory and the File.Exists methods do not require READ permission on Android 11+ (as it should be the case). On AI2 both blocks need READ permission incorrectly (on all Android versions).

But both methods do not need READ permission on any Android version.

See also here:

Yes, that is the problem (bug). If WRITE permission is declared in the Manifest on Android 11+, it is ignored and handled the same way as READ permission (because WRITE does no longer exists on Android 11+).

1 Like

Okay, i think i misunderstood your post.


Here just a few links to the AI2 forum:

This issue in Beta saver . Please solve this,

Then Google is wrong, because if WRITE permission is declared in the manifest on Android 11+ then (as I said before) this permission has the same effect as READ permission.
writePermissionOnAndroid11plus.apk (4.8 MB)

:exclamation: EDIT: Of course, to test my APK (on Android 11+), you must have manually copied any image (with the filename “Avatar_720.jpg” to the /Download directory beforehand.

Click on Button2 and grant (READ) permission.