Your Project Contains Ad Components. Upgrade your account

I built my project (migrated from AI2) yesterday multiple times (more than 10 times) without any problems on Niotron.

Today I get this message (with exactly the same project, aia):

:upside_down_face:

There are no Ads at all in my project.
@Souvik @Krish

I have NEVER used ads, neither with AI2, nor with Kodular, nor with Niotron, nor with Thunkable, nor with AppyBuilder, nor anywhere else. I don’t like ads in apps at all.

Strange, can you please try building in a incognito window ? Sometimes cache causes this issue

1 Like

Ok thanks, I’ll try …

1 Like

I completely cleared cache and browsing history using Firefox & Chrome. Restarted Firefox, called the builder: unfortunately the same result.

I’ll try again with Chrome in a moment …

Same with Chrome:

Here are all used extensions (no ads):

I can remove FloatingView ext, because I don’t use it.

I will now remove one by one and see if and when the project can be compiled …

Just weird that it worked fine yesterday. I have about a dozen APKs (build with Niotron) of it saved on my computer.

And even stranger, the project compiles as AAB without any problems. :upside_down_face:

I could of course also use the AAB and upload it in the Play Developer console, but I’m glad that with this project I have the opportunity to continue using APKs, since this app has been in the Play Store for more than 8 years.

After successfully building the AAB, I tried again as an APK.

And this time it worked:exclamation:

Whatever the cause of these problems may have been … :upside_down_face:

I signed out on Chrome and then tried again on Firefox. The same problem occurs again.

Then switched back to Chrome, logged into Niotron and now the same problem there again.

In addition, also the building of the AAB no longer works.

I think I have some experience with AI2 and its clones since I’ve been working with it for more than 10 years. But things like that have never happened to me before.

@Anke Read this :point_down:

1 Like

Thanks for the hint ! :ok_hand:
I would never have thought of that. Ok, so I have to create my own extension for this with another suitable (legal :wink:) name.

Nevertheless, it remains strange why this worked without any problems yesterday and at least once today with the APK and AAB. :upside_down_face:

And I just tried again: Both were built, APK & AAB. :upside_down_face:

1 Like

And after this, almost 10 times again successfully …

1 Like

Well yea right. I forgot to me mention the extension thing. Some extension has similar names with ad networks that’s why it can false detect sometimes.

Yes, as you said “can” detect false.
Isn’t there a way to solve this issue?

Well yea solution is either have to change the package name of the extension or we have to make changes in our ad detection algorithm

1 Like

Yes, I created my own extension with a simple packageName (de.bodymindpower.layout).
But that’s cumbersome and shouldn’t really be necessary.

1 Like