Help! i want save my ad unit in airtable database

I was using this way on other platform in saving my admob AD units on Airtable database but unfortunately I tried the same way on Niotron builder but its not working although there are slight differences. can somebody put me through?

this is the picture of my blocks

this is the picture of my database

where I’m I mistaken?

1 Like

In your database you have written Ads Id as table name but in your blocka you have written Ad Id.


thank you, i updated but still not working

I am pretty sure that the structure of the block (Logic) is not correct.

1- Always use the response from the airtable server to know that the connection is correct and you have no problem with it.

2- Try to load the ads after assigning the values and not before, I see that you put them on the recent login screen to load, but airtable response times are sometimes slow and may be the values are being assigned blank so load blocks put them underneath after assigning the properties or in a separate process and then just call them.

Hope this helps!

1 Like

@Quantumtec this is how i was using it in other platform, and it works

i will be glad if you help me here is the aia file
adsnefa.aia (264.4 KB)

the aia is niotron based aia

Niotron has different blocks, events and code are not the same as the other platforms, don’t expect it to work the same way, in some blocks the structure of the block library will have to be changed.

Keep that in mind!


@Quantumtec I believe you friend please can you offer me a helping hand?

Yes, I’m on it
only the banner doesn’t work and the logic you were using was wrong.

Ads Load

1 Like

Thank you I appreciate your kindness, more greese to your elbow


Well the banner never loaded but the other two admob ads work fine.

with the banner I hope some staff will give us help

Error with the banner

Ways I tried to load the banner

Post: I realised that I put the Ads IDs backwards jajaja, I put them in order and the banner still doesn’t work.

I hope it helps!
I can’t do much modifying because I don’t have an Ads account jajaja xD

AIA Modified
adsnefa_Modify.aia (264.9 KB)

You have really tried, I appreciate your effort and I wish you success in all your endeavors

1 Like