Apk builder not working properly

Today on 8 May 2024 when I visit builder.niotron.com and try to test my apk with companion than every components, extensions and their respective blocks were working fine, according to changes that I made everything loading properly but when I finalize my work and try to build apk than apk also got build but the problem is that some components and some blocks are not working after running apk, which causes errors in my app and also some changes are not showing which I made in my app but in companion everything is working fine. Anybody can help me in solving these errors please :pleading_face:.

@Sharafat_Ali can you list all the errors with screenshot with respective blocks?

Sure I am uploading that.

:point_up::point_up: Watch in this video that every blocks and components are working fine in companion.

:point_down::point_down: And watch after compiling the app how some blocks and components are not working.

And see which block is not working​:point_down:

And in screen 1 I have set custom typeface typeface file for bubble tab bar extension which is working fine in companion but not working after compiling the app​:point_down:

I have already initialized fetch downloader extension during screen initialisation but this block and some more blocks of dynamic components extensions are not working after compiling the app while everything is working fine in companion.

Any reply please??

@Sharafat_Ali Which android version you have? this could be a permission problem

or else try calling the initialize block on button click as well that is two times initializing maybe it is not able to detect the first one… if non of these works you need to ask the developer

Android 14.

But, when I compile my same project’s aia in beta server than there I am not getting error from fetch downloader extension blocks everything working fine but I am getting error from dynamic components extensions. One more error in main server is that some blocks are not saving.

what error are you getting?

ok @Sharafat_Ali I’ll tell the team regarding this

1 Like

Remove id blocks are not working some time.

Yes, you are right I am using android version 14 for testing than I am getting this error that write external storage permission has denied

How can I solve this error on Android 14? And if I try to give write external storage permission in screen1 than I am getting error 908 on Android version 14


This can’t be solved now i think as builder are not having android 14 support you can add the permissions in the app but builder’s current blocks are not designed to work upon android 14. Please try targeting till android 13 for a better experience

Can you provide the error screenshot and the specific blocks which are causing error?

But when compiling my project on beta server with same blocks and extension and without asking any permission it is working fine in android 14 because using this extension I am not asking for external storage I am using app default asd path to store files.

Watch in this video that there is no problem after compiling the app from beta server from fetch downloader extension.

I have fixed that error of dynamic components extensions but watch this that I am not getting any error on beta server after compiling the app why?

Can I publish my app on playstore by compiling my app on beta server will I have to face any problem in future if I published my app on playstore.

Firebase google sign in is not working in beta server.

Any reply please??

Yes, you can if the app is working properly and you make sure your keystore is correct.

Sorry for the late reply…

is the app crashing? or login is not working? And which service (Facebook, google, or email or phone) are you using?

1 Like

No, app is not crashing everything is working fine and only Google sign-in (Google) not working even I have added SHA-1 fingerprint in my firebase project.

Google sign-in problem has been solved now, the problem was that in beta I have not initialized firebase core because that one was new block which has been added.

1 Like

Now that means your problem is solved?

1 Like